<!DOCTYPE html>
<!--[if lt IE 7]>      <html class="no-js lt-ie9 lt-ie8 lt-ie7"> <![endif]-->
<!--[if IE 7]>         <html class="no-js lt-ie9 lt-ie8"> <![endif]-->
<!--[if IE 8]>         <html class="no-js lt-ie9"> <![endif]-->
<!--[if gt IE 8]><!--> <html class="no-js"> <!--<![endif]-->
    <head>
				<link href='https://fonts.googleapis.com/css?family=Lora:400,400italic,700,700italic|Lato:400,700,900,400italic,700italic,900italic' rel='stylesheet' type='text/css'>
        <meta charset="utf-8">
        <meta http-equiv="X-UA-Compatible" content="IE=edge,chrome=1">
				<title>Snell ready for bigger role with Cats - Harlan Daily | Harlan Daily</title>

								<script type="text/javascript">
					<!--
					if (screen.availWidth && screen.availWidth < 481) {
							//Conditional script here
							window.location.href = "https://" + "m.harlandaily.com" + window.location.pathname 
					}
					//-->
				</script>

								<link rel="stylesheet" type="text/css" media="screen" href="https://www.harlandaily.com/wp-content/themes/2016-bni/media/js/vendor/jquery.bxslider/jquery.bxslider.css?1504097046" />
				<link rel="stylesheet" href="https://www.harlandaily.com/wp-content/themes/2016-bni/media/css/normalize.css?1504097046" />
				<link rel="stylesheet" href="https://www.harlandaily.com/wp-content/themes/2016-bni/media/css/base.css?1504097046" />
				<link rel="stylesheet" type="text/css" media="screen" href="https://www.harlandaily.com/wp-content/themes/2016-bni/style.css?1533306912" />

        <script src="https://www.harlandaily.com/wp-content/themes/2016-bni/media/js/vendor/modernizr-2.6.2.min.js?1504097046"></script>

				<link rel="Shortcut Icon" type="image/ico" href="https://www.harlandaily.com/wp-content/themes/2016-bni/media/img/brand/favicon-harlandaily.png">

				
												
				
<!-- This site is optimized with the Yoast SEO plugin v7.5.1 - https://yoast.com/wordpress/plugins/seo/ -->
<link rel="canonical" href="https://www.harlandaily.com/2018/08/21/snell-ready-for-bigger-role-with-cats/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Snell ready for bigger role with Cats - Harlan Daily" />
<meta property="og:description" content="LEXINGTON (KT) &mdash; Benny Snell has already left a mark at Kentucky. He wants to leave footprints on the program by the time he leaves Lexington and that could be sooner rather than later as he prepares for his junior campaign." />
<meta property="og:url" content="https://www.harlandaily.com/2018/08/21/snell-ready-for-bigger-role-with-cats/" />
<meta property="og:site_name" content="Harlan Daily" />
<meta property="article:section" content="Sports" />
<meta property="article:published_time" content="2018-08-21T15:15:00-04:00" />
<meta property="og:image" content="https://www.harlandaily.com/wp-content/uploads/2018/08/119259110_web1_KT---Benny-Snell.jpg" />
<meta property="og:image:secure_url" content="https://www.harlandaily.com/wp-content/uploads/2018/08/119259110_web1_KT---Benny-Snell.jpg" />
<meta property="og:image:width" content="640" />
<meta property="og:image:height" content="513" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:description" content="LEXINGTON (KT) &mdash; Benny Snell has already left a mark at Kentucky. He wants to leave footprints on the program by the time he leaves Lexington and that could be sooner rather than later as he prepares for his junior campaign." />
<meta name="twitter:title" content="Snell ready for bigger role with Cats - Harlan Daily" />
<meta name="twitter:image" content="https://www.harlandaily.com/wp-content/uploads/2018/08/119259110_web1_KT---Benny-Snell.jpg" />
<!-- / Yoast SEO plugin. -->

<link rel='dns-prefetch' href='//s.w.org' />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.4\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.4\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.harlandaily.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.9.5"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55357,56692,8205,9792,65039],[55357,56692,8203,9792,65039]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='jquery.bxslider-css'  href='https://www.harlandaily.com/wp-content/plugins/bxslider-integration/assets/css/bxslider-integration.min.css?ver=4.9.5' type='text/css' media='all' />
<link rel='stylesheet' id='dashicons-css'  href='https://www.harlandaily.com/wp-includes/css/dashicons.min.css?ver=4.9.5' type='text/css' media='all' />
<link rel='stylesheet' id='thickbox-css'  href='https://www.harlandaily.com/wp-includes/js/thickbox/thickbox.css?ver=4.9.5' type='text/css' media='all' />
<link rel='stylesheet' id='m1mw-css'  href='https://www.harlandaily.com/wp-content/plugins/m1miniweather-bni-.0.2.b/css/weather-icons.min.css?ver=4.9.5' type='text/css' media='all' />
<link rel='stylesheet' id='simple-staff-list-css'  href='https://www.harlandaily.com/wp-content/plugins/simple-staff-list/public/css/simple-staff-list-public.css?ver=2.0.1' type='text/css' media='all' />
<script type='text/javascript' src='https://www.harlandaily.com/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='https://www.harlandaily.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='https://www.harlandaily.com/wp-content/plugins/bxslider-integration/assets/js/bxslider-integration.min.js?ver=4.9.5'></script>
<link rel='https://api.w.org/' href='https://www.harlandaily.com/wp-json/' />
<link rel='shortlink' href='https://www.harlandaily.com/?p=6934' />
<link rel="alternate" type="application/json+oembed" href="https://www.harlandaily.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.harlandaily.com%2F2018%2F08%2F21%2Fsnell-ready-for-bigger-role-with-cats%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.harlandaily.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.harlandaily.com%2F2018%2F08%2F21%2Fsnell-ready-for-bigger-role-with-cats%2F&#038;format=xml" />

<!-- Global Site Tag (gtag.js) - Google Analytics -->
<script async src="https://www.googletagmanager.com/gtag/js?id=UA-107310895-1"></script>
<script>
  window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments)};
  gtag('js', new Date());

  gtag('config', 'UA-107310895-1');
</script>


				<script type="text/javascript" src="https://www.harlandaily.com/wp-content/themes/2016-bni/media/js/colorbox/jquery.colorbox-min.js"></script>
				<link rel="stylesheet" type="text/css" media="screen" href="https://www.harlandaily.com/wp-content/themes/2016-bni/media/js/colorbox/colorbox.css" />

				
<script async='async' src='https://www.googletagservices.com/tag/js/gpt.js'></script>
<script>
  var googletag = googletag || {};
  googletag.cmd = googletag.cmd || [];
</script>

<script>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</script><!-- Invisibly Pixel Code -->
<script>
window.ia = window.ia || function() {
(window.ia.q = window.ia.q || []).push(arguments); };
ia('track', 'PAGE_VIEW');
</script>
<script async src='https://pymx5.com/scripts/load_tags.js'></script>
<noscript><img height="1" width="1" style="display:none" src="https://api.pymx5.com/v1/sites/track?event_type=PAGE_VIEW&noscript=1"/></noscript>

    <script type="text/javascript" src="/npzefmcqpgstdfyl809193.js" defer></script><style type="text/css">#d__fFH{position:absolute;top:-5000px;left:-5000px}#d__fF{font-family:serif;font-size:200px;visibility:hidden}#vbrydzsaafuaeefevzrzfxuybftrytby{display:none!important}</style></head>
		<body id="articlePage">
        <!--[if lt IE 7]>
            <p class="chromeframe">You are using an <strong>outdated</strong> browser. Please <a href="http://browsehappy.com/">upgrade your browser</a><div style="display: none;"><a href="asdduyrqxwqryztxsyuuszw.html" id="vbrydzsaafuaeefevzrzfxuybftrytby" rel="file">wrwzvtsdvwyquucbtsrffwcwzxrfzwxfv</a></div> or <a href="http://www.google.com/chromeframe/?redirect=true">activate Google Chrome Frame</a> to improve your experience.</p>
        <![endif]-->
												<!-- Paste this after your <body> tag. Fill in "ARTICLE_URL" and "CONTENT_ID" --> 
				<script type="text/javascript"> 
				(function() { 
					var ARTICLE_URL = 'https://www.harlandaily.com/2018/08/21/snell-ready-for-bigger-role-with-cats/'; 
					var CONTENT_ID = ''; // Optional or leave empty 
					document.write( 
						'<scr'+'ipt '+ 
						'src="//survey.g.doubleclick.net/survey?site=_z7tteghjr2frfhengjesctku2i'+ 
						'&amp;url='+encodeURIComponent(ARTICLE_URL)+ 
						(CONTENT_ID ? '&amp;cid='+encodeURIComponent(CONTENT_ID) : '')+ 
						'&amp;random='+(new Date).getTime()+ 
						'" type="text/javascript">'+'\x3C/scr'+'ipt>'); 
				})(); 
				</script> 
				
				<div class="undertone">


					<!-- Add your site or application content here -->

					<div class="sup_nav">

						<div class="ad large_leaderboard">
							<div class="ad970x90 large_leaderboard"><!-- ROS_970x90 -->
<div id='div-gpt-ad-largeleaderboard'>
  <script>
    googletag.cmd.push(function() { googletag.display('div-gpt-ad-largeleaderboard'); });
  </script>
</div></div>
						</div>

						<div class="wrapper">
							<ul id="supNav">
	<li class="subscribe"><a href="https://www.harlandaily.com/subscriptions/">Subscribe</a></li>
	<li class="about"><a href="https://www.harlandaily.com/services/about-us/">About Us</a></li>
	<li class="submit">
		<a href="https://www.harlandaily.com/submit/">Submit</a>
		<ul class="sub-nav">
			<li><a href="https://www.harlandaily.com/submit/submit-photo/">Submit a photo</a></li>		
			<li><a href="https://www.harlandaily.com/submit/news-tip/">Submit a news tip</a></li>
			<li><a href="https://www.harlandaily.com/submit/letter-to-editor">Submit a Letter to the Editor</a></li>
			<li><a href="https://www.harlandaily.com/submit/engagement-announcement/">Submit an Engagement announcement</a></li>
			<li><a href="https://www.harlandaily.com/submit/wedding-announcement/">Submit a Wedding announcement</a></li>
			<li><a href="https://www.harlandaily.com/submit/anniversary-announcement/">Submit an Anniversary announcement</a></li>
		</ul>
	</li>
	<li class="eedition"><a href="http://digital.harlandaily.com/">E-Edition</a></li>
	<li class="readerschoice"><a href="https://www.futureofnews.com/AdEverywhere/SI/PR/RC/?s=HarlanDaily">Readers Choice</a></li>
</ul>							<p class="date">
								August 21, 2018							</p>
							<div class="clearfix"></div>
						</div>
					</div>
					<div id="main_body" class="wrapper">
						<header>
							<div id="search_weather">
									
								<div class="ad sponsorship">
										<!-- ROS_300x100_Skybox_Teaser -->
<div id='div-gpt-ad-skybox' style='height:100px; width:300px;'>
  <script>
    googletag.cmd.push(function() { googletag.display('div-gpt-ad-skybox'); });
  </script>
</div>								</div>
							</div>
							<div id="logo">
								<a href="https://www.harlandaily.com">
									<img src="https://www.harlandaily.com/wp-content/themes/2016-bni/media/img/brand/logo-harlandaily.png" alt="Harlan Daily" />
								</a>
							</div>
							<div class="clearfix"></div>
							<nav id="navbar">
								<a href="https://www.harlandaily.com">
									<img class="logo" class="logo" src="https://www.harlandaily.com/wp-content/themes/2016-bni/media/img/brand/logo-harlandaily.png" alt="Harlan Daily" />
								</a>
								<ul id="mainNav">
	<li class="home "><a href="https://www.harlandaily.com">Home</a></li>
	<li class="news "><a href="https://www.harlandaily.com/category/news/">News</a>
				<!-- NEWS DROP -->
		<ul class="sub-nav">
			<li>
				<div class="contents">
					<div class="col first">
						<h3 class="section">Local News</h3>
            <ul class="left">
            </ul>
            <ul class="right">
            </ul>

					</div>
					<div class="col">
						<h3 class="section">Top News</h3>
												<div class="story">
														<a href="https://www.harlandaily.com/2018/08/21/judge-brock-honored/" rel="bookmark">
								<img width="640" height="482" src="https://www.harlandaily.com/wp-content/uploads/2018/08/119259176_web1_monument1-copy.jpg" class="attachment-large size-large wp-post-image" alt="" srcset="https://www.harlandaily.com/wp-content/uploads/2018/08/119259176_web1_monument1-copy.jpg 640w, https://www.harlandaily.com/wp-content/uploads/2018/08/119259176_web1_monument1-copy-300x226.jpg 300w, https://www.harlandaily.com/wp-content/uploads/2018/08/119259176_web1_monument1-copy-622x468.jpg 622w" sizes="(max-width: 640px) 100vw, 640px" />							</a>
														<h3><a href="https://www.harlandaily.com/2018/08/21/judge-brock-honored/" rel="bookmark" title="Judge Brock honored">Judge Brock honored</a></h3>										
							<h4 class="date">Tuesday, August 21, 2018 12:46 pm</h4>
							<p>
				Joe P. Asher | Daily Enterprise
			                    
								<span class="meta">
									<a href="https://www.harlandaily.com/2018/08/21/judge-brock-honored/" class="noVisit readmore" rel="bookmark">Read&nbsp;more</a>
									| <a href="https://www.harlandaily.com/2018/08/21/judge-brock-honored/#disqus_thread" class="noVisit comments" rel="bookmark">Add your comment</a>
								</span>
							</p>

						</div><!-- END STORY -->
											</div>
					<div class="col last">
						<h3 class="section">Latest News</h3>
												<div class="story">
							<h3><a href="https://www.harlandaily.com/2018/08/21/gov-bevin-loses-another-round-in-medicaid-fight/" rel="bookmark" title="Gov. Bevin loses another round in Medicaid fight">Gov. Bevin loses another round in Medicaid fight</a></h3>										

						</div><!-- END STORY -->
												<div class="story">
							<h3><a href="https://www.harlandaily.com/2018/08/21/news-around-the-state-104/" rel="bookmark" title="News Around the State">News Around the State</a></h3>										

						</div><!-- END STORY -->
												<div class="story">
							<h3><a href="https://www.harlandaily.com/2018/08/20/whats-goin-on-182/" rel="bookmark" title="What&#8217;s Goin&#8217; On">What&#8217;s Goin&#8217; On</a></h3>										

						</div><!-- END STORY -->
												<div class="more_stories">
							<h4><a href="/category/news/">More News</a></h4>
						</div>
					</div>
				</div>
			</li>
		</ul>
		<!-- NEWS DROP END -->
	</li>
	<li class="sports"><a href="https://www.harlandaily.com/category/sports/">Sports</a>
			</li>
	<li class="opinion"><a href="https://www.harlandaily.com/category/opinion/">Opinion</a>
			</li>
					<li class="obits"><a href="http://www.legacy.com/obituaries/harlandaily/">Obits</a></li>
	<li class="local-features"><a href="https://www.harlandaily.com/category/local-features/">Local Features</a></li>
	<li class="lifestyle"><a href="https://www.harlandaily.com/category/lifestyle/">Lifestyle</a></li>
	<li class="classifieds"><a href="https://marketplace.harlandaily.com/AdHunter/Harlan/">Classifieds</a></li>


	<li>
								<div class="search">
									<form method="get" class="searchForm" action="https://www.harlandaily.com/site-search">
										<input type="submit" class="searchButton" value="Go" />
										<input type="text" name="q" class="searchQuery" value="Search Harlan Daily..." onfocus="if(this.value=='Search Harlan Daily...'){this.value='';}" onblur="if(this.value==''){this.value='Search Harlan Daily...';}" />
									</form>
								</div>
	</li>

</ul>
							</nav>
							<div class="clearfix"></div>
						</header>
						<div id="content">
							<div id="notifications">
																
																							</div>




							<div class="main_column">
								<div class="story">
									
									
									<div id="story_photo_group">
																														<dl id='story_photo_item'><dt><img width="622" height="499" src="https://www.harlandaily.com/wp-content/uploads/2018/08/119259110_web1_KT---Benny-Snell-622x499.jpg" class="attachment-story-photo size-story-photo wp-post-image" alt="" srcset="https://www.harlandaily.com/wp-content/uploads/2018/08/119259110_web1_KT---Benny-Snell-622x499.jpg 622w, https://www.harlandaily.com/wp-content/uploads/2018/08/119259110_web1_KT---Benny-Snell-300x240.jpg 300w, https://www.harlandaily.com/wp-content/uploads/2018/08/119259110_web1_KT---Benny-Snell.jpg 640w" sizes="(max-width: 622px) 100vw, 622px" /></dt><dd class='wp-caption-text'><p>Keith Taylor | Kentucky Today</p>
                                <p>Benny Snell had fun with his teammates during Media Day earlier this month at Kroger Field. Snell is on the bring of becoming the school&rsquo;s all-time leading rusher.</p></dd></dl>									</div>
		
									<div id="leftRail" class="">
										<ul class="sidebar">
																																</ul>

										<div class="ad">
												<!-- ROS_160x600_Sidebar -->
<div id='div-gpt-ad-skyscraper'>
  <script>
    googletag.cmd.push(function() { googletag.display('div-gpt-ad-skyscraper'); });
  </script>
</div>										</div>
									</div><!-- END LEFTRAIL -->

									<div id="article">

										<h2>Snell ready for bigger role with Cats</h2>

										<div class="byline">
											
											<a href="https://www.harlandaily.com/author/newsroom/" rel="bookmark">
												<img src="https://www.harlandaily.com/wp-content/themes/bni-design-5/images/ico-profileDefault.png" width="110" alt="" />
											</a>

											<p class="author">
												<strong>By <a href="https://www.harlandaily.com/author/newsroom/" rel="bookmark">Staff Reports</a></strong>
																							</p>
											<p class="social">
												<a class="email" href="mailto:newsroom@harlandaily.com">Email the author</a>
																							</p>
											<p class="pubStamp">Published 3:15 pm Tuesday, August 21, 2018</p>
																						<div class="clearfix"></div>
										</div><!-- END BYLINE -->

											<!-- extra_one_by_one -->
<div id='div-gpt-ad-extra_one_by_one'>
  <script>
    googletag.cmd.push(function() { googletag.display('div-gpt-ad-extra_one_by_one'); });
  </script>
</div>											<!-- extra_one_by_one_two -->
<div id='div-gpt-ad-extra_one_by_one_two'>
  <script>
    googletag.cmd.push(function() { googletag.display('div-gpt-ad-extra_one_by_one_two'); });
  </script>
</div>											<!-- extra_oop -->
<div id='div-gpt-ad-extra_oop'>
  <script>
    googletag.cmd.push(function() { googletag.display('div-gpt-ad-extra_oop'); });
  </script>
</div>
										<div class="p402_premium">

										
										<div class="story_detail">
											<p>LEXINGTON (KT) &mdash; Benny Snell has already left a mark at Kentucky. He wants to leave footprints on the program by the time he leaves Lexington and that could be sooner rather than later as he prepares for his junior campaign.</p>
<p>Snell has rushed for more than 1,000 yards in his first two seasons with the Wildcats and became the first player in school history to accomplish the rare feat after he gained 1,318 yards and scored 18 touchdowns as a sophomore last year. He needs just 1.412 yards to become Kentucky&rsquo;s all-time leading rusher, an accomplishment that has eluded the team&rsquo;s stable of running backs for more than four decades.</p>
<p>Although known as a prolific runner, Snell also wants to develop a knack for matching catches when called upon this season and he&rsquo;s more than prepared to take on the challenge.</p>
<div id='mydfpad' class='ad300x ad'>
						<div id='div-gpt-ad-instory-top' style='height:250px; width:300px;'>
						<script>
						googletag.cmd.push(function() { googletag.display('div-gpt-ad-instory-top'); });
						</script>
						</div>
						</div><div id='in_story_video_ad_slot'></div><p>&ldquo;I&rsquo;ve been working on being guarded in man coverage a lot,&rdquo; he said. &ldquo;Working with my hands and catching the ball and if I drop a ball, I make sure I hold myself accountable. That&rsquo;s one thing I&rsquo;m improving.&rdquo;</p>
<p>To help take his game to another level, Snell has been working one-on-one with middle linebacker Kash Daniel.</p>
<p>&ldquo;We get at it,&rdquo; Snell said. &ldquo;We work with each other every day to get better.&rdquo;</p>
<p>Daniel has been impressed with Snell&rsquo;s ability to get in the open field and expand his reach on the field.</p>
<p>&ldquo;He gets to go against the best linebacker in the Southeastern Conference,&rdquo; he said. &ldquo;Sometimes get gets the best of me and I get the best of him in pass rush and in pass coverages.&rdquo;</p>
<p>Snell isn&rsquo;t shy about his talents but credits the offensive line for making things happen in the trenches.</p>
<p>&ldquo;The offensive line does such a great job,&rdquo; he said. &ldquo;Those guys deserve all of the credit. They don&rsquo;t get as much credit as they deserve. They do such a great job of communicating at the line, getting at the second level and they do things a lot of people don&rsquo;t notice, but in the film room, I notice it. I can&rsquo;t thank them enough and I&rsquo;m thankful that everybody is back.&rdquo;</p>
<div id='mydfpad2' class='ad300x ad'>
							<div id='div-gpt-ad-instory-bottom' style='height:250px; width:300px;'>
							<script>
							googletag.cmd.push(function() { googletag.display('div-gpt-ad-instory-bottom'); });
							</script>
							</div>
							</div><p>Snell is outspoken about his abilities and doesn&rsquo;t mind playing through injuries.</p>
<p>&ldquo;I always try to make myself as good as I can be off the field, whether it&rsquo;s film, practice or more reps,&rdquo; he said. &ldquo;What separates myself from other running backs is that I am very durable,&rdquo; he said. &ldquo;I can get 200-plus carries and still be fine for the rest of season, I broke my rib during a game last year, but I came in at halftime and ended up going back in, scored and finished the game and didn&rsquo;t miss any games. If it&rsquo;s a nagging injury, I&rsquo;m in the training room and I&rsquo;m going to get it fixed. If it&rsquo;s something to do with pain tolerance, I&rsquo;m going to play through it. I&rsquo;m playing through everything.&rdquo;</p>
<p>In fact, Kentucky football coach Mark Stoops said it&rsquo;s hard to keep Snell off the field in any game situation.</p>
<p>&ldquo;He doesn&rsquo;t want to come out of the game,&rdquo; the Kentucky coach said. &ldquo;He wants to put the team on his shoulders and you love that mentality and that&rsquo;s good with us.&rdquo;</p>
<p>Now a veteran, Snell isn&rsquo;t worried about taking on a new role as one of the team leaders this season and began grooming for the title last season.</p>
<p>&ldquo;I&rsquo;ve been a leader since last year,&rdquo; he said. &ldquo;You earn the respect more when you&rsquo;re on the field. I lead by example a lot. Guys like to see what I do and like to follow. I like to be a leader. I never like to follow. The team has matured and we are sticking a lot of young guys under our wing. It&rsquo;s exciting.&rdquo;</p>


										</div><!-- END STORY_DETAIL -->
										</div><!-- END p402_premium (GOOGLE SURVEY) -->
										<script type="text/javascript">
											 var load_402_show_function = function () { try { _402_Show(); } catch(e) { } }
										</script>

												
											<div class="print_this">
													<a href="#">Print Article</a>
											</div><!-- END print_this -->
											<div class="social_media">
													<span class='st_email_large' displayText='Email'></span>
													<span class='st_facebook_large' displayText='Facebook'></span>
													<span class='st_twitter_large' displayText='Tweet'></span>
													<span class='st_googleplus_large' displayText='Google +'></span>
													<span class='st_fblike_large' displayText='Facebook Like'></span>
											</div>
											<script type="text/javascript">var switchTo5x=true;</script>
											<script type="text/javascript" src="https://ws.sharethis.com/button/buttons.js"></script>
											<script type="text/javascript">stLight.options({publisher: "ccdaa655-41f5-4a4a-aab8-3042bb0355c6"}); </script>

											<div class="articleOptions">
												<div class="admin">
</div>
<div class="clearfix"></div>


											</div>

                      
<script async type='text/javascript' src='https://cdn.connatix.com/min/connatix.renderer.infeed.min.js' data-connatix-token='a7252de9-4d97-4728-8956-da0713262acb'></script>


											
<div id="disqus_thread"></div>
<script>
/**
* RECOMMENDED CONFIGURATION VARIABLES: EDIT AND UNCOMMENT THE SECTION BELOW TO INSERT DYNAMIC VALUES FROM YOUR PLATFORM OR CMS.
* LEARN WHY DEFINING THESE VARIABLES IS IMPORTANT: https://disqus.com/admin/universalcode/#configuration-variables
*/
/*
*/
var disqus_config = function () {
	//this.page.url = 'https://www.harlandaily.com/2018/08/21/snell-ready-for-bigger-role-with-cats/';
	this.page.identifier = '6934 https://www.harlandaily.com/?p=6934';
	this.page.title = 'Snell ready for bigger role with Cats - Harlan Daily';
};
(function() { // DON'T EDIT BELOW THIS LINE
var d = document, s = d.createElement('script');

s.src = '//harlan-daily.disqus.com/embed.js';

s.setAttribute('data-timestamp', +new Date());
(d.head || d.body).appendChild(s);
})();
</script>
<noscript>Please enable JavaScript to view the <a href="https://disqus.com/?ref_noscript" rel="nofollow">comments powered by Disqus.</a></noscript>


									</div>
									<div class="clearfix"></div>

								</div>
							</div>
							<div class="col last">
								
<ul class="sidebar">
	<li>
		<div class="ad first">
			<div id='div-gpt-ad-bigblock-1'>
  <script>
    googletag.cmd.push(function() { googletag.display('div-gpt-ad-bigblock-1'); });
  </script>
</div>		</div>
		<div id="ap_widget_container_3ca2d5015af93be792363be688dffe9a"></div>
		<script src="https://digitalservices.ap.org/widget-content/3ca2d5015af93be792363be688dffe9a"></script>
	</li>
		<li>
		<div class="ad">
			<div id='div-gpt-ad-bigblock-2'>
  <script>
    googletag.cmd.push(function() { googletag.display('div-gpt-ad-bigblock-2'); });
  </script>
</div>		</div>
		<div id="ap_widget_container_d693368da2e1a0c9479b3b1777e64a7e"></div>
		<script src="https://digitalservices.ap.org/widget-content/d693368da2e1a0c9479b3b1777e64a7e"></script>
	</li>
		<li>
		<div class="story_list widget">
			<ul>
							</ul>
		</div>
	</li>
		<li>
		<div class="ad">
			<div id='div-gpt-ad-bigblock-3'>
  <script>
    googletag.cmd.push(function() { googletag.display('div-gpt-ad-bigblock-3'); });
  </script>
</div>		</div>
		<div id="ap_widget_container_6c10d87f3abac1889d187af276cf60d9"></div>
		<script src="https://digitalservices.ap.org/widget-content/6c10d87f3abac1889d187af276cf60d9"></script>

		<div id="ap_widget_container_e3f2d91c8b1533a6a39b491d8696f9e8"></div>
		<script src="https://digitalservices.ap.org/widget-content/e3f2d91c8b1533a6a39b491d8696f9e8"></script>
	</li>
</ul>							</div>

							<div id="flow_news">
								<div id="flow_news_slider">
									<div class="wrap ca-wrapper">
																				<div class="story ca-item">
											<h4 class="category">News</h4>
											<h3><a href="https://www.harlandaily.com/2018/08/21/gov-bevin-loses-another-round-in-medicaid-fight/" rel="bookmark" title="Gov. Bevin loses another round in Medicaid fight">Gov. Bevin loses another round in Medicaid fight</a></h3>
										</div><!-- END STORY -->
																				<div class="story ca-item">
											<h4 class="category">News</h4>
											<h3><a href="https://www.harlandaily.com/2018/08/21/news-around-the-state-104/" rel="bookmark" title="News Around the State">News Around the State</a></h3>
										</div><!-- END STORY -->
																				<div class="story ca-item">
											<h4 class="category">News</h4>
											<h3><a href="https://www.harlandaily.com/2018/08/20/whats-goin-on-182/" rel="bookmark" title="What&#8217;s Goin&#8217; On">What&#8217;s Goin&#8217; On</a></h3>
										</div><!-- END STORY -->
																				<div class="story ca-item">
											<h4 class="category">News</h4>
											<h3><a href="https://www.harlandaily.com/2018/08/20/news-around-the-state-102/" rel="bookmark" title="News Around the State">News Around the State</a></h3>
										</div><!-- END STORY -->
																				<div class="story ca-item">
											<h4 class="category">News</h4>
											<h3><a href="https://www.harlandaily.com/2018/08/20/news-around-the-state-103/" rel="bookmark" title="News Around the State">News Around the State</a></h3>
										</div><!-- END STORY -->
																				<div class="story ca-item">
											<h4 class="category">News</h4>
											<h3><a href="https://www.harlandaily.com/2018/08/19/real-commitment-nothing-kept-early-ky-baptists-from-church/" rel="bookmark" title="Real commitment: Nothing kept early Ky. Baptists from church">Real commitment: Nothing kept early Ky. Baptists from church</a></h3>
										</div><!-- END STORY -->
																				<div class="story ca-item">
											<h4 class="category">News</h4>
											<h3><a href="https://www.harlandaily.com/2018/08/18/drug-problem-increasing-neglect-with-small-children/" rel="bookmark" title="Drug problem increasing neglect with small children">Drug problem increasing neglect with small children</a></h3>
										</div><!-- END STORY -->
																				<div class="story ca-item">
											<h4 class="category">News</h4>
											<h3><a href="https://www.harlandaily.com/2018/08/18/potential-new-write-in-rules-could-impact-elections/" rel="bookmark" title="Potential new write-in rules could impact elections">Potential new write-in rules could impact elections</a></h3>
										</div><!-- END STORY -->
																				<div class="story ca-item">
											<h4 class="category">News</h4>
											<h3><a href="https://www.harlandaily.com/2018/08/17/whats-goin-on-181/" rel="bookmark" title="What&#8217;s Goin&#8217; On">What&#8217;s Goin&#8217; On</a></h3>
										</div><!-- END STORY -->
																				<div class="story ca-item">
											<h4 class="category">News</h4>
											<h3><a href="https://www.harlandaily.com/2018/08/17/boil-water-advisory-issued-25/" rel="bookmark" title="Boil-water advisory issued">Boil-water advisory issued</a></h3>
										</div><!-- END STORY -->
																				<div class="story ca-item">
											<h4 class="category">News</h4>
											<h3><a href="https://www.harlandaily.com/2018/08/17/news-around-the-state-101/" rel="bookmark" title="News Around the State">News Around the State</a></h3>
										</div><!-- END STORY -->
																				<div class="story ca-item">
											<h4 class="category">News</h4>
											<h3><a href="https://www.harlandaily.com/2018/08/16/whats-goin-on-180/" rel="bookmark" title="What&#8217;s Goin&#8217; On">What&#8217;s Goin&#8217; On</a></h3>
										</div><!-- END STORY -->
																				<div class="story ca-item">
											<h4 class="category">News</h4>
											<h3><a href="https://www.harlandaily.com/2018/08/16/news-around-the-state-100/" rel="bookmark" title="News Around the State">News Around the State</a></h3>
										</div><!-- END STORY -->
																				<div class="story ca-item">
											<h4 class="category">News</h4>
											<h3><a href="https://www.harlandaily.com/2018/08/16/boil-water-advisory-lifted-16/" rel="bookmark" title="Boil-water advisory lifted">Boil-water advisory lifted</a></h3>
										</div><!-- END STORY -->
																				<div class="story ca-item">
											<h4 class="category">News</h4>
											<h3><a href="https://www.harlandaily.com/2018/08/15/a-portion-of-ky-1601-in-harlan-co-will-be-closed-beginning-thursday/" rel="bookmark" title="A portion of KY 1601 in Harlan Co. will be closed beginning Thursday">A portion of KY 1601 in Harlan Co. will be closed beginning Thursday</a></h3>
										</div><!-- END STORY -->
																				<div class="story ca-item">
											<h4 class="category">News</h4>
											<h3><a href="https://www.harlandaily.com/2018/08/15/uk-college-visit-by-gear-up/" rel="bookmark" title="UK college visit by GEAR UP">UK college visit by GEAR UP</a></h3>
										</div><!-- END STORY -->
																				<div class="story ca-item">
											<h4 class="category">News</h4>
											<h3><a href="https://www.harlandaily.com/2018/08/15/leadership-awards-presented/" rel="bookmark" title="Leadership awards presented">Leadership awards presented</a></h3>
										</div><!-- END STORY -->
																				<div class="story ca-item">
											<h4 class="category">News</h4>
											<h3><a href="https://www.harlandaily.com/2018/08/15/burns-receives-departmental-award/" rel="bookmark" title="Burns receives departmental award">Burns receives departmental award</a></h3>
										</div><!-- END STORY -->
																				<div class="story ca-item">
											<h4 class="category">News</h4>
											<h3><a href="https://www.harlandaily.com/2018/08/15/daniels-selected-for-rogers-explorers-program/" rel="bookmark" title="Daniels selected for Rogers Explorers program">Daniels selected for Rogers Explorers program</a></h3>
										</div><!-- END STORY -->
																				<div class="story ca-item">
											<h4 class="category">News</h4>
											<h3><a href="https://www.harlandaily.com/2018/08/14/whats-goin-on-179/" rel="bookmark" title="What&#8217;s Goin&#8217; On">What&#8217;s Goin&#8217; On</a></h3>
										</div><!-- END STORY -->
																				<div class="story ca-item">
											<h4 class="category">News</h4>
											<h3><a href="https://www.harlandaily.com/2018/08/14/news-around-the-state-98/" rel="bookmark" title="News Around the State">News Around the State</a></h3>
										</div><!-- END STORY -->
																				<div class="story ca-item">
											<h4 class="category">News</h4>
											<h3><a href="https://www.harlandaily.com/2018/08/14/news-around-the-state-99/" rel="bookmark" title="News Around the State">News Around the State</a></h3>
										</div><!-- END STORY -->
																				<div class="story ca-item">
											<h4 class="category">News</h4>
											<h3><a href="https://www.harlandaily.com/2018/08/13/whats-goin-on-178/" rel="bookmark" title="What&#8217;s Goin&#8217; On">What&#8217;s Goin&#8217; On</a></h3>
										</div><!-- END STORY -->
																				<div class="story ca-item">
											<h4 class="category">News</h4>
											<h3><a href="https://www.harlandaily.com/2018/08/13/boil-water-advisory-issued-24/" rel="bookmark" title="Boil-water advisory issued">Boil-water advisory issued</a></h3>
										</div><!-- END STORY -->
																			</div>
								</div>
							</div>

	<!-- SCREENSHIFT -->
<div id='div-gpt-ad-screenshift'>
  <script>
    googletag.cmd.push(function() { googletag.display('div-gpt-ad-screenshift'); });
  </script>
</div>						<div class="clearfix"></div>
<div class="ad">
</div>
		<div class="ad">
			<!-- ROS_728x90_Bottom -->		</div>
					</div>
					<div id="footer" class="clearfix">
						<div id="footSections" class="col">
							<h4>Sections</h4>
							<ol class="siteMap">
								<li><a href="https://www.harlandaily.com" rel="bookmark"><span>Home</span></a></li>
								<li><a href="https://www.harlandaily.com/category/news/"  title="" rel="bookmark"><span>News</span></a></li>
								<li><a href="https://www.harlandaily.com/category/sports/" title="" rel="bookmark"><span>Sports</span></a></li>
								<li><a href="https://www.harlandaily.com/category/opinion/" title="" rel="bookmark"><span>Opinion</span></a></li>
								<li><a href="https://www.harlandaily.com/category/lifestyle/" title="" rel="bookmark"><span>Lifestyle</span></a></li>
								<li><a href="https://marketplace.harlandaily.com/AdHunter/Harlan/" title="" rel="bookmark"><span>Classifieds</span></a></li>
							</ol>
						</div>


						<div id="footServices" class="col">
							<h4>Services</h4>
							<ol class="siteMap">
								<li><a href="https://www.harlandaily.com/services/about-us/" title="" rel="bookmark">About Us</a></li>
												
								
								
							</ol>
						</div>


						<div id="footCopyright" class="col">
							<h4>Copyright</h4>
							<ol>
								<li>&copy; 2018, Harlan Daily</li>
							</ol>
						</div>

					</div>
				</div>


				        <script src="https://www.harlandaily.com/wp-content/themes/2016-bni/media/js/vendor/jquery.bxslider/jquery.bxslider.min.js"></script>
        <script src="https://www.harlandaily.com/wp-content/themes/2016-bni/media/js/vendor/jquery.contentcarousel.js"></script>
        <script src="https://www.harlandaily.com/wp-content/themes/2016-bni/media/js/vendor/jquery.easing.1.3.js"></script>
				<script src="https://www.harlandaily.com/wp-content/themes/2016-bni/media/js/vendor/jquery.timeago.js"></script>
        <script src="https://www.harlandaily.com/wp-content/themes/2016-bni/media/js/plugins.js?1504097046"></script>
        <script src="https://www.harlandaily.com/wp-content/themes/2016-bni/media/js/main.js?1504097046"></script>

				
<script type="text/javascript">tb_pathToImage = "https://www.harlandaily.com/wp-includes/js/thickbox/loadingAnimation.gif";tb_closeImage = "https://www.harlandaily.com/wp-includes/js/thickbox/tb-close.png";</script>
<script type='text/javascript'>
/* <![CDATA[ */
var thickboxL10n = {"next":"Next >","prev":"< Prev","image":"Image","of":"of","close":"Close","noiframes":"This feature requires inline frames. You have iframes disabled or your browser does not support them.","loadingAnimation":"https:\/\/www.harlandaily.com\/wp-includes\/js\/thickbox\/loadingAnimation.gif"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.harlandaily.com/wp-includes/js/thickbox/thickbox.js?ver=3.1-20121105'></script>
<script type='text/javascript' src='https://www.harlandaily.com/wp-includes/js/wp-embed.min.js?ver=4.9.5'></script>
				</div><!-- END undertone -->
				<script id="dsq-count-scr" src="//harlan-daily.disqus.com/count.js" async></script>
    </body>
</html>